Why should you upgrade your Joomla website design from 1.0.x to 1.5.x?


Is it really important to upgrade your Joomla website design from 1.0.x to 1.5.x? Joomla 1.5 code has been re-written to make it more user friendly and scalable in terms of development.

For site administrators, the look and feel of the admin panel has been significantly revamped. The extension installer has been merged so that components, modules, plugins and languages can be installed and managed from single tab.

The media manager has become very user friendly with Ajax based uploader and ability to view the media in icons and list formats.

The article manager has become simpler to use. Now there is a single editor with a “Read More” button for separating the introduction from the full article. The addition of images in the content has improved a lot using Ajax. Now updating the articles on sites like News Portal has become quite fast.

The global configuration has been organized better. The option to enable SEF urls is a great relief. The inbuilt SEF urls are very good for small sites. Another good option is to edit the menu item for menu type which was not present in 1.0.

For designers and developers, the code base has been better organized by separating program logic from presentation logic. Now, template designers can use custom layouts, often referred to as template overrides. A beautiful addition is the ability to define template parameters which can be managed from the Template Manager.

And last but not the least, one of the most powerful features of the framework is the new MVC based component objects.  Developing using the MVC design pattern gives developers a platform for rapid application development and prototyping.  The clear separation between logic and presentation helps ensure code reusability and maintainability.

In all, Joomla web design 1.5.x version is far better and great than 1.0.x. If you are installing Joomla on a new site, it’s preferable to start with 1.5 versions. The joomla community has also quickened the pace and you will find that most of the popular extensions are now 1.5 native.

Please note: Comment moderation is enabled and may delay your comment. There is no need to resubmit your comment.